Degraded credit card authentication

Incident Report for Cleverbridge Platform Status

Resolved

This incident has been resolved, situation is back to normal. We see systems performing normal again. We apologize for any inconvenience.
Posted Apr 02, 2025 - 15:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 02, 2025 - 14:57 UTC

Identified

We have identified the root cause of the issue and are working on a fix.
Posted Apr 02, 2025 - 14:50 UTC

Update

We are still investigating this issue to identify root cause.
Posted Apr 02, 2025 - 13:53 UTC

Investigating

We're investigating performance issues with our 3DS authentication service. We're doing everything possible to identify and work closely with our partners to resolve these issues. We apologize for any inconvenience.
Posted Apr 02, 2025 - 13:02 UTC