Delayed Payment Processing
Incident Report for cleverbridge
Resolved
This incident has been resolved.
All captured orders will be processed automatically.
Posted Jun 23, 2020 - 12:15 CEST
Identified
We have identified a delay in order processing. The issue has been identified and we are working on the solution.

Please note that only a small percentage of our orders are affected due to one of our payment providers.
We have switched to our backup providers until the issue is resolved.
Posted Jun 23, 2020 - 11:23 CEST