Delayed order processing
Incident Report for cleverbridge
Resolved
This incident has been resolved.
Posted Feb 11, 2020 - 16:31 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 11, 2020 - 13:48 CET
Identified
The issue has been identified and we are working on the solution.

Please note that only a small percentage of our orders is affected due to one of our payment providers.
We have switched to one of our backup providers until the issue is resolved.
Posted Feb 11, 2020 - 12:36 CET
Investigating
We are currently experiencing a problem with order processing. Incoming orders are accepted, but the processing is delayed.
Posted Feb 11, 2020 - 12:28 CET