Delayed Payment Processing
Incident Report for Cleverbridge Platform Status
Resolved
This incident has been resolved by our payment acquirer.
We will shortly start to reprocess the affected orders and there is no additional interaction required.
Posted Apr 18, 2021 - 10:09 UTC
Identified
After scheduled maintenance by one of our payment acquirer, we are currently experiencing processing errors for renewals.
The issue has been reported and identified. The payment acquirer is working on the solution.

During the maintenance, we have switched to one of our backup acquirers.
We switch back traffic, once the issue is fully resolved.

Once the issue is resolved, all orders will be reprocessed without further interaction.
Posted Apr 18, 2021 - 08:51 UTC