Delayed order processing
Incident Report for cleverbridge
Resolved
Since 1:10 PM UTC order processing happens again in real-time.
Posted 3 months ago. Jan 24, 2018 - 14:17 CET
Identified
We are currently experiencing a problem with order processing. Incoming orders are accepted, but the processing is delayed.
Posted 3 months ago. Jan 24, 2018 - 14:02 CET